A couple of shout-outs and the next lesson learned again

First, to Lexar, for actually supporting a product! (Telling of the times that that’s worth a shout-out…) When I bought my R5, 18 months ago, I got a Lexar 128 GB SD UHS II card for the second slot, to back up the CFexpress card. It was always much slower to format than the CFexpress card, but I didn’t know that was not normal. But a couple of months ago it started to fail to format in the camera, although it still would in the computer. I figured that was a couple of hundred bucks down the drain, but in looking up the specs for a replacement I saw that Lexar advertised a lifetime guarantee on the card. So I contacted them, and to my astonishment, after jumping through a few hoops, they have given me a refunded for today’s cost. (They would have replaced it but are currently unable to get them! But I got one from B&H.)

And secondly, to Other World Computing, for great tech support. They have been a go-to source for Mac stuff for years, and when I decided I was ready to take my Drobo out back and shoot it, I got their Mercury Elite Pro Quad enclosure, which runs SoftRAID. I removed the 6TB Seagate Iron Wolf drives from the Drobo and began the setup process, and right away got failures on an initial test to “verify” the drives (test readability of all sectors). Had the Drobo trashed the drives? Did I have a faulty housing? It turns out, no – I had one of Apple’s recurrent “features” – a new state-of-the-art (allegedly) M1 Pro MacBook Pro with a brand new OS (Monterey) which was not exactly ready for prime time, even after two updates. The problem was that the RAID software has had some technical issues with “some” computers, due to the new security settings. Tech support said the solution was to set the RAID stripe to 64kb instead of the default. I’m repeating the verification, which will take about 9 hours per disk, but that will hopefully report all is now well. (I’ll report back if not.) Then after another maybe 2 days copying my photography library from the backup drive (yes, 2 copies, one off-site), I should be back in business.


Well, ANOTHER lesson learned. An expensive one at this point. Long story short, I am out about $1300 for a RAID housing and drives for my Mac Pro that is apparently incompatible. I have spent THREE WEEKS trying to get an image storage system working to replace a problem-plagued Drobo, and bought a Mercury Elite Pro Quad from Other World Computing. Their tech support “sounds” good – obviously people in this country (the company is in the Chicago area) but I’m in an endless loop with them trying to figure out why their RAID system won’t work with my “latest and greatest” Mac Book Pro M1 Pro. After many emails and calls, they shipped an RMA replacement for what they decided must be a faulty housing, but they expect me to pay shipping and insurance to return the original. I don’t think that’s how RMA works. AND the replacement housing has the same issues the original one did. Current troubleshooting seems to indicate it is incompatible with the Mac’s Thunderbolt connection, contrary to advertising. Not only that but the problem initially appeared to be the drives I removed from the Drobo, so I bought 4 new ones from them, for $870, and it appears now the drives were never the problem.

So I need to do a 180 on my recommendation for this company. Calls to tech support get a new person each time who has no idea of the issue, and emails replying to an established case # generate a new number each time. I appear to be screwed. I will report back if I finally find otherwise.

OMG I am so sorry. There is hardly anything more frustrating and maddening than tech issues. Of course the shitty communication at Other World isn’t helping. I worked for many technology resellers over the years and know that tech support software is capable of doing a lot to avoid repetition and to ensure good information with details. How stupid.

That it’s taking you away from photography and other things you love is even worse. All I can do is hope it is sorted soon. I haven’t pulled the trigger on a new laptop and will just muddle along with my occasionally irritating Windows 10 Lenovo.

UPDATE – and I do hope it’s the last one. After almost a month without access to my LR files, the third RAID storage unit from Other World Computing seems to be working. It seemed like a good idea to replace my Drobo, which has been a constant nuisance with random unmounts requiring hard shutdowns, taking multiple tries to get restarted and failing to re-mount when the computer restarts. I thought the OWC Mercury Elite Pro looked like a good choice – it would do RAID 5 with what sounded like good software and I could re-use the drives from the Drobo and have a spare to cover any failure. The software does disk checks and that seemed like a good idea, as the drives were 4 years old. The verification started reporting failures and after several calls and emails to tech support, it appeared the disks were bad, so I ordered a set they recommended, to the tune of over $800. But putting them in the unit, the failures continued. So they did an RMA swap for the housing. The new one had the same failures! After much troubleshooting they decided the original unit was not compatible with the Thunderbolt ports on the new M1 MacBook Pro (although I had checked with them about that before buying it!) and suggested I get the ThunderBay unit instead – for an additional $300. Then I had to insist on a proper RMA exchange – they wanted me to pay shipping and insurance to return the second unit that didn’t work!!! So I set up the new unit and started verifying the disks in it. It ran through the set, returned an error that one was bad, but each individually showed it was good. More calls and emails. I ran the same test again and this time it said a DIFFERENT one was bad but each one individually showed good. Another call to tech support this afternoon (after my email of last night got no response). They think it is some spurious issue with the SoftRAID software and said they think everything will work as it should. So I’m starting to copy files back, which will take a while.

Between each verify test taking about 10 hours, emails going unanswered until I called (and getting a different support person each time), shipping delays and delays with weekends and this last holiday, this has been going on almost a month.

I had heard, although a while back, that they were a good outfit. Certainly not my experience.