Kenai River sunrise

This was taken in Alaska about 12 years ago near Cooper Landing. I reprocessed it and used luminosity masks to bring out some of the highlights in the water. This is early September.

Iso-100, don’t remember which lens I used, D2X, tripod, Adobe camera raw 10.5, Topaz adjust, TK luminosity masks, TK sharpening action at 5%

Yikes, now that’s a lot of water there…:smiley:
Sadly, this is one of those images that has fallen prey to not opening up to the larger version for some reason. I had one sometime back now that did that. Mark or Keith hopefully will come along and fix this one also.
Anyway, even at the normal size the view is impressive on a grand scale for a large waterway for sure. The back lighting seems to fit this scene nicely too…:sunglasses:

David, this is a good look at a big river sunrise. The details in the water show very well. The sun and the hints of mountain slopes add nicely to the setting. This opens fine to a larger view for me. One thing I have seen when I’ve uploaded images is it taking a minute or two before the full size view becomes available. I haven’t noticed that on other images, but I haven’t paid careful attention either. It may be an occasional slowness in the web site’s response. BTW you forgot to add the 859 tag, but I’ve fixed that.

Hey Mark, yes it opens just fine now. I wonder if David or Keith fixed it as I tried early this morning and there was no photo in place for awhile. I suspect it might have been being repaired at that time possibly…:thinking:

EDIT: I just noticed and opened up the pencil edit and yes this morning it was worked on by someone. I did not see any changes in verbiage so I assume it was the photo being fixed.

Hi Paul, check out my response to Norma about web site responsiveness.

Mark, I did look at that image posted by Norma just now and read your comment. But, like David’s image I also looked at the pencil edit at the very top above the OP’s message and the image posted there was another edit without verbiage being changed. So, again did someone go into the post and fix the image?
Anyway, it might be Gremlins too…the software type and not the AMC Rambler type…:stuck_out_tongue_winking_eye: