Cannot save photos as a Jpeg in Photoshop

Hi everyone,
Last night I could save images as Jpeg but I suddenly I can’t. I do not even get the large drop down menu. All I get is save as a large document TIFF PSB. I am in 8bit mode. Nothing has changed and I am trying to edit photos from last night. Photoshop did an update today and everything seemed to change. I tried resizing the image and that did not work. This is really frustrating and I am hoping someone can help. Thanks, Brian

I am confused about your report. Usually there is no TIFF PSB, only TIFF or PSB (Large Document). File sizes greater than 2GB cannot be stored as a PSD, and sizes greater than 4 GB cannot be saved as a TIFF. Therefore, anything greater that 4 TB must be saved as a PSB. That being said, Photoshop can be very buggy at times, at least with a MAC, which is what I use. I suggest doing the following things, one at a time and move on to the next if you haven’t solved the problem:

  1. Close Photoshop, reboot your computer, and reopen Photoshop.
  2. Delete Photoshop preferences (google how to do that). Don’t forget to reset your preferences again.
  3. Use the Adobe Creative Cloud app to delete Photoshop, then reinstall (again, don’t forget to reset preferences).
  4. Use the Adobe Creative Cloud Cleaner Tool (google to find) then reinstall Photoshop.
    Good luck!
1 Like

I uninstalled photoshop and reinstalled. The same problem exists. But I tried photoshop elements and had no issues.

From the File Menu, Choose “Save a Copy”, rather than “Save As…” and you will have all of the file formats possible including Jpeg. If the file has layers, “Save As…” will only have “Photoshop”, “Large Document Format”, and “Tiff”. If the layers have been merged or flattened, you’ll have other options but Jpeg may not be there, “Jpeg 2000” will likely be there. You can also choose “File / Save As…” and from that dialog box choose “Save a Copy”

Thankyou Keith. I will give it a try. I never had to do it that way before so I wonder what happened. Maybe the recent update caused some quirks.

Check out the “What’s New” from the Help Menu in Photoshop . You’ll see a summary of all the changes and specifically it talks about this change.

Bummer. You could try the last step, using the Adobe Cleaner. The problem is that Photoshop creates all sorts of files that are hidden and don’t get thrown away when you reinstall. Once after uninstalling and reinstalling (and choosing not to have any preferences saved) the newly installed Photoshop auto installed some of my old preferences. I think these hidden files can get corrupted and cause problems. I had a problem with Photoshop (all of the brushes for various tools would freeze) and after trying all of the steps I outlined I managed to talk to Adobe and the only thing they suggested was to reformat my hard drive and reinstall Photoshop. That solved the problem but as you can imagine was a major pain to reinstall all my other stuff that got wiped out. The other thing that they suggested was to create a new user on my computer and see if the problem persisted. I didn’t do that, too complicated for me. Perhaps your problem is a bug that will get corrected soon. My last piece of advice: turn off auto update Photoshop and don’t update until a second update comes out. In other words, always stay an update behind. Each update always produces some bugs which usually get corrected in the next update.

@Tony_Siciliano There is nothing to be fixed. As noted in the What’s New information about 22.4 it explains exactly what change was made and how to save to different file types.

Cool! Much ado about nothing.

Good morning Keith. Thank you for your help. There is nothing to fix. I was just surprised to see it suddenly happen. I now use Save a copy.
Tony, thankyou for your help as well.