Trouble posting for critique

I’m experiencing something new. When I click on Post Image for Critique, the form is pre-populated with a prior image I had posted, along with all the original text. When I erase all the text and upload a new image, and click “Continue” to get to the next page for applying a Tag, the edits I made are gone and the original pre-populated entry is shown, both text and image.
Is there some kind of “cache” I need to clear out?
@David_Kingham , any ideas on fixing this?

I just had the same thing happen!! I let it post and deleted it, now will see if I can post what I meant to.

I tried that too. I created a “test” discussion and posted it. Then I deleted it. Then I tried to create a new post and am getting the same issue.

Maybe we’re being cancelled.

It seems to be a bug that was introduced with an update today. You’ll have to revert to using the Classic Composer until this is resolved. Sorry for the trouble, hopefully this can be fixed swiftly!

1 Like

I’m having trouble reproducing this myself but I know it is a real problem. If anyone that is a bit tech savvy is willing to help out I would appreciate it and it will help us get to a solution quicker.

  1. Please go to and ensure you are still having the same problem
  2. Then open your browser console, instructions on how to do that here How to Open the Browser Console on Chrome, Safari, Firefox, and Edge -
  3. If you see any errors in red please take a screenshot of that and post it here.

Thank you!

@David_Kingham , here is the red text from m y Google Chrome browser console

Thanks for creating that option for the “Photo/Discussion” button. I was able to post using Classic Composer. Will patiently await the fix!

I did a retry in the Classic Composer that worked.

Thank you Mark! Could you try one more thing for me? Go back to , if you still have the same problem could you try doing a hard refresh by holding down the Shift key and then click the refresh button in chrome and let me know if that fixes it.

@David_Kingham, Unfortunately I had the same problem when clicking the “critique” link. Going back to Google Chrome and holding Shift + refresh button (the clockwise-pointing circular arrow symbol) didn’t fix it. I’ve attached the different red text that appears in the Browser Console, if this helps.
(I also did Shift+refresh icon while on the “critique” page…no effect. Page still pre-loaded with image and text from a prior post)